読者です 読者をやめる 読者になる 読者になる

絶品ゆどうふのタレ

ふと気づいたことを綴るだけのメモ

Debian LennyでPHP5.3.1のパッケージを使う。

debian lenny php

まぁ既知だろうけど。


どうも世の中にはPHP5.3への懸念が強いらしく、debianはsqueezeでも5.3にならない。
追加リポジトリとしてLAMP系を作ってくれているところにDotdeb | The repository for Debian-based LAMP serversがあるけど、ここも標準だとPHP5.2.12にするとかそういうレベル。

けど、Dotdebはさすがで、PHP5.3用のパッケージを使えるように、別のdebリポジトリを作ってくれているw
PHP 5.3.1 packages for Debian “Lenny” : they’re here! | Dotdeb

ここにあるとおり、souruces.listに

deb http://php53.dotdeb.org stable all
deb-src http://php53.dotdeb.org stable all

を追加してあげればいい。

にしても、ここまで分けるかwww