読者です 読者をやめる 読者になる 読者になる

絶品ゆどうふのタレ

ふと気づいたことを綴るだけのメモ

CentOS 5.1にしたらlibpng-develの依存関係でエラー言われた。

タイトルで全部言った。

まぁ
# yum install libpng-develしたら

    • > Populating transaction set with selected packages. Please wait.
      • > Package libpng-devel.i386 2:1.2.10-7.0.2 set to be updated
      • > Package libpng-devel.x86_64 2:1.2.10-7.0.2 set to be updated
    • > Running transaction check
    • > Processing Dependency: libpng = 2:1.2.10-7.0.2 for package: libpng-devel
    • > Finished Dependency Resolution

Error: Missing Dependency: libpng = 2:1.2.10-7.0.2 is needed by package libpng-devel

とかいいだしたんだけど、
# rpm -qa|grep libpng
すると

libpng-1.2.10-7.1.el5_0.1
libpng-1.2.10-7.1.el5_0.1

とかゆってる。
よく見ると依存性が >= じゃなくて = だし!みたいなね。
さすがにlibpngはremoveできんし。
さーて、どうしよー♪


とかいってる間に、rpmwgetして何とかすることに。
うーん、他のライブラリの依存関係大丈夫だろうか。